loading...

Ubuntu 19.04 on a Dell Vostro 3750, Bluetooth & 802.11ac Not Functioning at the Same Time

Ubuntu 19.04 on a Dell Vostro 3750, Bluetooth & 802.11ac Not Functioning at the Same Time

So this has taken up way more of my time this evening than I expected it to.

Nowadays, I only run Windows on my Steam gaming machines, for obvious reason. Otherwise, it’s Ubuntu all the way, baby, yeah!

Except…eh, no…

https://askubuntu.com/questions/645009/wi-fi-and-bluetooth-not-working-simultaneouslyhttps://askubuntu.com/questions/1051149/intel-centrino-wireless-n-1030-wireless-drop-after-reboot-ubuntu-16-04 have so far yielded me nothing functional. Edit: see, this is weird, as this – https://askubuntu.com/questions/672590/slow-wifi-internet-when-connected-to-other-bluetooth-device says to set:

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi bt_coex_active=0"

Instead of:

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi bt_coex_active=N"

Turn on laptop. Connect to wifi. Speed all evening.

Turn on Sennheisers HD4.40s to casually listen to music while working on my first failed screenplay, BOOM, packet latency through the roof. Disable Bluetooth, immediately back to speeds I was expecting.

Edit: interestingly, there seems to be some issues going on Internet-wide with a bunch of sites right about the time I’m testing this. I may have to back-burner my suspicions until tomorrow morning. I can see a difference, but not a *big* difference, best I can tell.

With Bluetooth enabled, and the headphones connected:
Screenshot from 2019-06-23 00-52-43

Screenshot from 2019-06-23 00-53-10

Disabling Bluetooth:

Screenshot from 2019-06-23 00-53-36

Screenshot from 2019-06-23 00-54-00

So, more to be determined at a later time. I wanted to write something this evening; I just wasn’t expecting it to be this.

C’est la vie.

0 7